recurring Cygnal/SDCC port compile problem

pabloroblesgil wrote on Tuesday, July 23, 2013:


I have been, unsuccesfully, trying to build the 8051 (cygnal) port for several days.

I followed the steps in the tutorial and added SDCC as well as UnxUtils to my PATH

I unzipped the re-built lib functions into the scdd/…/large directory as indicated.

SDCC works fine as I am able to compile *.c files (e.g example.c)

already tried with several sdcc snapshots from version 2.3 to version 3.3 if I remember well.

Im sure UnxUtils works fine as well. (particularly make v 3.78.1 by the way)

No matter what I do I get this error, which othe people already posted on the following threads, however with no apparent or obvious solution to the issue

sdcc -c -model-large -I. -I…/Common/include -I…/include -I…/…/Source/includ         e -DSDCC_CYGNAL -debug -less-pedantic -xram-size 8448 -stack-auto -no-peep          -int-long-reent -float-reent ParTest/ParTest.c
process_begin: CreateProcess((null), sdcc -c -model-large -I. -I…/Common/inclu         de -I…/include -I…/…/Source/include -DSDCC_CYGNAL -debug -less-pedantic -x         ram-size 8448 -stack-auto -no-peep -int-long-reent -float-reent ParTest/ParT         est.c, …) failed.
make (e=2): El sistema no puede encontrar el archivo especificado.
C:\UnxUtils\usr\local\wbin\make.exe: ***  Error 2

Any help will be much appreciated.
Best Regards,

pabloroblesgil wrote on Tuesday, July 23, 2013:

It might be useful to know im running windows 7 and have already tried using cmd and cygwin, with identical unsuccesful results.

rtel wrote on Wednesday, July 24, 2013:

You can see the last item under “legacy issues” in the known issues list:

Are you using the compiler version stated on the documentation page or a newer version?

Unfortunately there are no plans to update to the code to allow use with the current SDCC compielr.