[lpc2368 telned] How to add telnetd

mikemd23 wrote on Thursday, March 01, 2012:

Dear All,

I am new in the FreeRtos and uip stack domain. I have successfully built the demo
project (ARM7_LPC2368_Eclipse) for
LPC2368 under Eclipse (indigo) + Yogarto (gcc2.6.0) + openocd-0.5.0.

I have had problems to run the demo project compiled with Sourcery gcc cross
development toolchain (gcc 2.6.1) and
yogarto (gcc 2.6.2). The Demo project compiles with whatever development
toolchain but it does not run. It only runs if I have compiled it with
yogarto (gcc2.6.0).

The place were it fails is the boot.s file:

ldrb r4, , #1 -> jump
ldr pc, _dabt /* data abort - _dabt */
                  -> jump
__dabt: b . /* data abort */

Does anybody know the reason for that?

My second question is about the telnetd daemon. I have tried to place the
existing code of the telnetd
from FreeRTOSV7.1.0\Demo\uIP_Demo_IAR_ARM7\uip:
ie. files: telnetd.c, telnetd.h, telnetd-shell.c, memb.c, memb.h

to the directory:


I have placed in the  uip_Task.c just after httpd_init() the telnetd_init()

the code (with few modifications) compiles but when I run it and connect
with telnet I get the connection but it is closed automatically after few

I have seen few posts on this mailing list about porting the telnetd to the
webserver project but I did not find the actual code for that. I would be
grateful for some indication where to find the proper implementation of
telnetd (for FreeRTOS) for uip stack or maybe even FreeTCPIP?

Best Regards


rtel wrote on Thursday, March 01, 2012:

Did you use the same start up file (crt.o, or whatever) and linker script with all the different compiler versions?  This demo is quite old so it will have been originally tested with an older version of Yagarto.


mikemd23 wrote on Friday, March 02, 2012:

I have used the original project from FREERTOS Demo (ARM7_LPC2368_Eclipse). I have just hanged the compiler name to arm-none-eabi-gcc since the older name (prefix has changed). The original project has the assembler file called boot.s with some preliminary setup. This is actually the place where the whole system fails when compiled and linked with (gcc 4.6.1 onwards). Yogarto gcc 4.6.0 looks still fine.

rtel wrote on Friday, March 02, 2012:

Maybe the Yagarto people would have an explanation?


mikemd23 wrote on Friday, March 02, 2012:

I have installed Yogartu (gcc 4.6.0) on another computer with windows XP and compilation is successful but the executable (elf file) when loaded to my LPC2368 fails exactly the same way as described in my first post? Does some environmental variable influence FreeRtos demo project during compilation and linkage?

Best Regards