FreeRTOS LPC2148 won`t debug

brtom wrote on Sunday, January 10, 2010:


I have tried the last few days to get FreeRTOS with the Yagarto Toolchain to run and have failed. I`ve tried to change the LPC2368 Example in the FreeRTOS directory but with no success.
So I have taken a LPC2148 project which compiles and debugs wonderfull and tried to add FreeRTOS.
But, if I add the FreeRTOS c and object files (tasks.c, port.c, heap_1.c, portISR.c,  list.c) the whole thing compiles but no longer debugs. It starts to download and at 27% it stops after the “continue” message for a minute and then exits with this error message:

Breakpoint 1, main () at src/main.c:98
98 initialize();
Current language:  auto; currently c
mi_cmd_disassemble: Invalid filename.

At the moment I have absolut no Idea what i made wrong. If i comment the FreeRTOS lines in the makefile the whole thing works again.
Thanks in advance,

rtel wrote on Sunday, January 10, 2010:

Take a look at Take a look at

which has some comprehensive projects that build and run on LPC2148’s.


brtom wrote on Sunday, January 17, 2010:

I have tried again the JCWRENs Port of the FreeRTOS and this time, I was able to get the thing to run :wink:
But, I have another DEBUG Problem.
I can`t stop the thing if i started it once, which is quite a very useless Debuging Session.
It stops once, in the main.c at the first statement and if i say GO, I can`t stop it again (OpenOCD says “Warn: target not halted”).
If wasn`t able to find anything usefull on the internet that solves my problem, so please give me at least a hint what I am doing wrong.
My Configuration for arm-elf-gdb in Eclipse is nearly the same as in the Yagarto Tutorial:
target remote localhost:3333
monitor reset init
monitor sleep 500
monitor mww 0xE01FC040 0x0001
monitor mdw 0xE01FC040
# needed for gdb 6.8 and higher
set mem inaccessible-by-default off

tbreak main