General Help with Eclipse and C

Please see the attached PIC. I’m trying to compile the AWS DEMOS [] on a custom PCB. I’ve had vanilla freertos running on it fine for a while. I’m having a little [a lot] of trouble getting the code to compile because of my lack of c skills. The code i’m sure is fine as i haven’t changed it, but am just trying to get my project set up right.
Can someone please tell me how this error is cropping up when it shouldn’t be included.
Also, what does the little blue pin/screw mean in the circle on the left.


Could you look at the console and see if the -I directives are OK?

This is where I defined the include paths:


But I am not an Eclipse expert neither :frowning:

Looks normal to me.

My problem is globally declaring MBEDTLS_CONFIG_FILE = “aws_mbedtls_config.h”.
The IDE shows it in the display but is not using it during build or something like that.
It works when i run the demo on the demo board but just having trouble moving to another project. in the demo project it’s under here.

but it won’t let me edit it so i put it here.

That’s the only difference i can see between the 2. I don’t even know what CTD means.

Apparently CDT stands for " C/ C++ Development Tooling".

When I add a symbol to user symbols, it does not appear in the gcc command line.
But when I use Paths and Symbols, it does appear in the parameters.



it appears as -DTEST_SYMBOL=1 in the parameter list.

THANKS! I hadn’t even looked under the symbols tabs for difference’s. That solved those errors and now a dozen more appear. In the famous words of the Terminator “I’ll be back”. But I’ll try for a few days first.