pkvasan wrote on September 05, 2019:

I am trying to connect my ST B-L475E-IoT01A kit to AWS by following steps as mentioned in AWS resources. All the required credentials ware entered and downloaded the zip file. I am using AC6 workbench to compile the downloaded file.

I get following error while attempting to build the project :
make: *** [vendors/st/stm32l475_discovery/STM32L4xx_HAL_Driver/stm32l4xx_hal.o] Error 1aws_demos C/C++ Problem
recipe for target ‘vendors/st/stm32l475_discovery/STM32L4xx_HAL_Driver/stm32l4xx_hal.o’ failed /aws_demos/Debug/vendors/st/stm32l475_discovery/STM32L4xx_HAL_Driver line 84 C/C++ Problem

Please guide on how do I solve this error

Gaurav-Aggarwal-AWS wrote on September 05, 2019:

I assume you followed the instructions here to build your project:

Did you use Quick Connect workflow? Which AWS region are you using?

I tried both “Quick Connect” and “Download from Amazon FreeRTOS Console” for STM32L4 and it builds successfully for me. Would you be able to share the source code zip you got so that we can take a look why is it failing?


Edited by: Gaurav-Aggarwal-AWS on Sep 5, 2019 12:19 PM

pkvasan wrote on September 06, 2019:

Hi Gaurav

Thanks for your response,
yes, I used Quick Connect workflow, using US-west-2 region.
I am not that familiar in using AC6, not able to understand what this error about?
I get this error :
recipe for target ‘vendors/st/stm32l475_discovery/STM32L4xx_HAL_Driver/stm32l4xx_hal.o’ failed

it points to this file --> at line no 84
Please help


Gaurav-Aggarwal-AWS wrote on September 06, 2019:

Which OS are you using? What is the version of AC6?

Did you follow the following steps to build as mentioned in the Getting Started Guide:

  1. Open the STM32 System Workbench and enter a name for a new workspace.
  2. From the File menu, choose Import. Expand General, choose Existing Projects into Workspace, and then choose Next.
  3. In Select Root Directory, enter projects/st/stm32l475_discovery/ac6/aws_demos.
  4. The project aws_demos should be selected by default.
  5. Choose Finish to import the project into STM32 System Workbench.
  6. From the Project menu, choose Build All. Confirm the project compiles without any errors.


pkvasan wrote on September 07, 2019:

I fixed it, the issue was with AC6 my folder had blank space and AC6 was not compiling, corrected it and build was a success

Thanks for your help