davitec wrote on Friday, July 04, 2008:

Recently purchased the development kit SAM7-EX256, I use Eclipse Platform 3.2. I have read the information found on page well have seen the example (demo SAM7X WEB Server & Mouse USB Demo Using Eclipse, GCC and OpenOCD for a completely open source development environment) which is in the same site. However I do not understand if I use the folder containing the DEMO, or if I have to use what is in the folder SOURCE. If someone can help me appreciate that I desire to prove the Ethernhet and USB; I just want to know is that I have files to import project in Eclipse. Thanks!

davedoors wrote on Saturday, July 05, 2008:

The demo directory contains the project file and the source code that demonstrates the use of FreeRTOS. The Source directory holds the FreeRTOS source code itself. Did you see the page ?

davitec wrote on Wednesday, July 09, 2008:

Yes I read the page, however need to know the steps to download the demo in the development kit, or need to know which files should I add to my project? Which are needed?
Thank you for your help!

rtel wrote on Wednesday, July 09, 2008:

The Eclipse projects use standard makefiles, which contain a list of all the files you require.  Look at the makefile included in the SAM7 demo directory to find the info you require.


davitec wrote on Thursday, July 10, 2008:

Hello again!
I have followed his recommendation, I saw the Makefile and I have seen files that are needed to import but when trying to download I get the following error:

make -k all
arm-elf-gcc -c -g -O3 -Tatmel-rom.ld -I . -I C:/FreeRTOS/FreeRTOS/Source/include -I C:/FreeRTOS/FreeRTOS/Source/portable/GCC/ARM7_AT91SAM7S -I C:/FreeRTOS/FreeRTOS/Demo/Common/include -I ./webserver -I C:/FreeRTOS/FreeRTOS/Demo/Common/ethernet/uIP/uip-1.0/uip -I ./SrcAtmel -I ./USB -D SAM7_GCC -D THUMB_INTERWORK -mcpu=arm7tdmi -D PACK_STRUCT_END=__attribute\(\(packed\)\) -D ALIGN_STRUCT_END=__attribute\(\(aligned\(4\)\)\) -fomit-frame-pointer -mthumb-interwork -mthumb main.c -o main.o
make: *** No rule to make target `ParTest/ParTest.c’, needed by `ParTest/ParTest.o’.
make: *** No rule to make target `webserver/uIP_Task.c’, needed by `webserver/uIP_Task.o’.
make: *** No rule to make target `webserver/httpd.c’, needed by `webserver/httpd.o’.
make: *** No rule to make target `webserver/httpd-cgi.c’, needed by `webserver/httpd-cgi.o’.
make: *** No rule to make target `webserver/httpd-fs.c’, needed by `webserver/httpd-fs.o’.
make: *** No rule to make target `webserver/http-strings.c’, needed by `webserver/http-strings.o’.
make: *** No rule to make target `webserver/SAM7_EMAC.c’, needed by `webserver/SAM7_EMAC.o’.
make: *** No rule to make target `USB/USBSample.c’, needed by `USB/USBSample.o’.
make: *** No rule to make target `webserver/emac_isr.c’, needed by `webserver/emac_isr.o’.
make: *** No rule to make target `SrcAtmel/Cstartup_SAM7.c’, needed by `SrcAtmel/Cstartup_SAM7.o’.
make: *** No rule to make target `USB/USB_ISR.c’, needed by `USB/USB_ISR.o’.
make: Target `all’ not remade because of errors.
make: write error

What can I do?

davedoors wrote on Thursday, July 10, 2008:

Looks like it simply cannot find the files. Check you have the paths to the files correct. If you are using Linux also check that the capitalization of the letters is correct.

sixscrews wrote on Friday, July 11, 2008:

I, too, have recently built this project.  Here’s how I did it -

I followed the posted website directions slavishly: Setup Eclipse, made sure it worked - run a sample Hello World!! project - if you have problems with that, fix them first.

Then, un-tar the latest FreeRTOS into a folder you have read/write rights to (somewhere in your home folder or desktop will work).

Then run Eclipse and point to the FreeRTOS/Demo/ARM7_AT91SAM7X256_Eclipse folder as your workspace.

Change the path FreeRTOS path name to the path of the ROOT of your RTOS directory.  On my system this is:


Make sure you edit the FOLDER form of the variable, not the FILE form.

If your paths are OK, a Refresh, as in the instructions, will give you a Project Explorer folder view that has no ‘!’ in the linked folder references (Common Demo Files and Source in my system) - the first two should have ‘link’ references in them (a small arrow as in Windows shortcuts).

From the last error listing you posted it looks like the FreeRTOS path name is still not quite right - the best guide to its correctness are the links mentioned above, and using an un-edited form of the Makefile - the ‘…/…/…’ sequences there are based on a correct form of the FreeRTOS root variable.

Wen you build your project you may have a few errors due to capitalization.  I have tracked down one, in the uIP_Task.h and uIP_Task.c references - the capitalization is not consistent between the include statements, the Makefile references and the actual names in the source folders.  I changed all instances of the string ‘uip_task,’ regardless of case or inclusion in a larger expression, to ‘uip_task’ and that fixed the problem (watch out for the ‘vuIP_Task’ reference in main.c, around line 134).  There may be a simpler way to fix this problem that leaves the ‘IP’ capitalized, but this is the approach I took.

Also, I had a problem with EMAC_ISR.c and changing it to emac_isr.c seems to have fixed that, too.

Hope this helps - I will be out of contact for the weekend, so my non-answer to  posts here is not due to loss of interest.