evkbimxrt1050_aws_shadow_enet

GeorgesOvon wrote on November 19, 2018:

Hi, I am new to AWS freertos. I am working on NXP-1050 devkit board, and tryin gto get evkbimxrt1050_aws_shadow_enet example program to run.

I have (tried) to following the instructions, but when I run the result, I get the log messages below.
“Command sent to MQTT task failed”

The AWS seems to register that a connection has been made, so I think the certificates are working. I think I must have missed a step.

Any help is welcome.

0 0 [Tmr Svc] Starting key provisioning…
1 0 [Tmr Svc] Write root certificate…
2 21 [Tmr Svc] Write device private key…
3 353 [Tmr Svc] Write device certificate…
4 367 [Tmr Svc] Key provisioning done…
5 26146 [Tmr Svc] Getting IP address from DHCP …
6 28146 [Tmr Svc] IPv4 Address: 192.168.1.130
7 28146 [Tmr Svc] DHCP OK
8 28152 [MainDemoTask] [Shadow 0] MQTT: Creation of dedicated MQTT client succeeded.
9 28160 [MainDemoTask] Sending command to MQTT task.
10 28164 [MQTT] Received message 10000 from queue.
11 28798 [MQTT] About to close socket.
12 28798 [MQTT] Socket closed.
13 28799 [MQTT] Notifying task.
14 28808 [MainDemoTask] Command sent to MQTT task failed.
15 28813 [MainDemoTask] [Shadow 0] MQTT: Connect failed.
16 28818 [MainDemoTask] Shadow_ClientConnect unsuccessful, returned 2.
17 28825 [MainDemoTask] Failed to initialize Shadow client.

abhijit-AWS wrote on November 22, 2018:

Hello GeorgesOvon

Based on these logs :

11 28798 [MQTT] About to close socket.
12 28798 [MQTT] Socket closed.
14 28808 [MainDemoTask] Command sent to MQTT task failed.

It looks like connection to MQTT server may have failed; it could be certificate or other issue that is causing connection problem.
Is it possible to get packet capture and see if TCP connection is failing/succeeding?

Also, would like to know what indicates that the connection has been made.

Thanks,
Abhijit