Compiling web server demo

fr4ncium wrote on Friday, November 28, 2008:

Hi all,

I’m trying to compile the freeRTOS web server demo for a AT91SAM7X256 described at

I am using the arm gcc toolchain to run the makefile, but get the following output
make: *** No rule to make target `Makefile’, needed by `…/…/Source/portable/GCC/ARM7_AT91SAM7S/portISR.o’.  Stop.

The object file does not exist anywhere in the parent directories.  Has anyone else encountered this problem or have suggestions?  I’m a bit of a Linux newbie and my google searches have not produced anything useful, so the only thing I can think of is to systematically download older versions of the demo until one compiles.

Thanks in advance - Happy Thanksgiving!

davedoors wrote on Friday, November 28, 2008:

makefile is used as a dependency on the build so if you change the makefile in any way the next time you do a build you get a complete rebuild. For some reason your make utility does not like it.

Are you using Linux? If so then check the case of the file name with the way it is written in the makefile. Maybe it should be ‘makefile’ with a small M. This would not show up on Windows builds.

Please report back if this is the case so Richard can fix it for future releases.

fr4ncium wrote on Saturday, November 29, 2008:

I decided to try compiling the demo in a Windows environment - running the makefile using cygwin worked.  The makefile is "makefile" - I tried changing it to "Makefile" and recompiling with the Linux gnu toolchain, but I got a lot more linking errors which ultimately terminated with an "Error 1". 

I’m guessing it is a case sensitivity issue, but my fledgeling Linux debugging attempts have yielded nothing.