Stm34F4: Infinite_Loop after memset

peterpan123321 wrote on Friday, August 31, 2012:

Hey. I am really not an expert, I am an hobbyist trying to work with FreeRTOS + STM32F4 (discovery board)
I managed to set up the toolchain (summon arm) and Eclipse IDE. “Plain” LED Blinking works fine.
I tried to add the FreeRTOS code to my project. I managed to compile the Source but when it comes to creating a task, I get stuck while debugging.

I fgured that eventually after ‘memset’ I end up in the “Infinite_Loop” trap in startup_stm32f3xx.S which is the processors handler for “unexpected interrupts”.

Ehm … I am lost. Totally.

These are the steps of my debugging session which lead to the trap.

main.c: xTaskCreate( testtask, ( signed char * ) "test", configMINIMAL_STACK_SIZE, NULL, mainQUEUE_RECEIVE_TASK_PRIORITY, NULL );
-> task.c(406): pxNewTCB = prvAllocateTCBAndStack( usStackDepth, puxStackBuffer );
-> -> task.c(2154): memset( pxNewTCB->pxStack, ( int ) tskSTACK_FILL_BYTE, ( size_t ) usStackDepth * sizeof( portSTACK_TYPE ) );
-> -> -> startup_stm32f3xx.S(121): b  Infinite_Loop


edwards3 wrote on Friday, August 31, 2012:

Have you installed the interrupt handlers?


peterpan123321 wrote on Saturday, September 01, 2012:


no I did not install the interrupt handlers correctly. Adding the #defines as mentioned in your linked threads did not solve the problem, however lead to some confusion (see below).

xTaskCreate() leads to a call of memset and strncpy in task.c (line 2154 and 1957) which then ends up in the handler for unexpected interrupts.
Reclessy removing those two calls from task.c worked, and two tasks are running as expected (as far as I can tell right now).
Of course thats not the way to go, so what is to blame for this problem?

There’s one thing I don’t get:
With and without the #defines for the interrupt handlers the code is working. Without it’s slower, but a breakpoint in xPortSysTickHandler() is reached in both cases. Why is xPortSysTickHandler() called in both cases?