Problem with ARM 7 and Eclipse

lukoido wrote on Wednesday, September 15, 2010:

I’m using Eclipse to compile FreeRTOS demo application for ARM7 and Eclipse (ARM7_AT91SAM7X256_Eclipse) but when I build it one error occur:

cc1.exe: error: unrecognized command line option “-fno-dwarf2-cfi-asm”

I tried to comment the -fno-dwarf2-cfi-asm CFLAGS and it works, compile without errors. But I don’t know if I can do this. When I try Run the demo using the OpenOCD Programmer a message appears saying:

terminate, exit value: -1073741515

Can any one help me with configuring the eclipse. I tried to follow the FreeRTOS instructions but it doesn’t work.

edwards3 wrote on Wednesday, September 15, 2010:

The instructions on the main FreeRTOS pages are out of date, Eclipse and OpenOCD have moved on since. You could try http://interactive.freertos.org/entries/206059-windows-eclipse-arm-toolchain-tutorial-for-beginners-in-german-based-on-stm32f103-cortex-m3 if you speak German or use Google translation.

lukoido wrote on Wednesday, September 29, 2010:

edwards3 I tried to use google translator and it works well. But I’m using OLIMEX AMR-USB-OCD and SAM7-EX256 Olimex development board (AT91SAM7X256 ARM7TDMI-S MICROCONTROLLER) that is different from the Cortex M4 that you use, and the tollchain seems to be different.
I need the FreeRTOS to complete one school project, that I need the arm board connected to internet via ethernet, and FreeRTOS.

Can anybody help me configuring eclipse for FreeRTOS and OLIMEX development board?