PIC32MZ with enc28j60

Hi everyone,
I have a project where i have to implement etherne module enc28j60 on pic32mz. I started with basic functions such as SPI, mac initialization, PHY configuration. and i test them with picoscope to make sure it works. When i tried to send an ethernet packet, the LED B blinks, but i cant see anything on the picoscope. i’m using a crossed cable.
Has anyone worked with a similar project ? i would be grateful for any help.

i recently tried the TCP/IP lite-weight stack which is used for the PIC18 series controller.
I can see that the SPI is working, but i don’t think that the PHY is working since it can’t read the physical status.

bool ETH_CheckLinkUp()
uint16_t phstat2;

phstat2 = ENC28_PhyRead(J60_PHSTAT2);

if(phstat2 & 0x0400)
    ethData.up = true;
    return true;
    return false;


It returns false all the time even when there is a link.

Is your question related to FreeRTOS? if not I suggest posting to the support forums on the Microchip website.