OpenOCD RTOS support - STM32F4

csorvagep wrote on Saturday, October 19, 2013:

Hi everyone!

I’ve just found out, that the OpenOCD has this feature, to support, and debug RTOSes. I’m trying to make it work, but I stuck.
The problem is that, the OpenOCD (0.7.0) says: “Error: No symbols for FreeRTOS”, and there is only one visible thread in the eclipse (kepler - cdt) I’ve check it with gdb and it has the same result. Btw: The FreeRTOS kernel runs fine, there’s no problem on that side.

I use the Sourcery CodeBench with Eclipse to compile. I’ve checked the symbols with the arm-none-eabi-nm command, and I found all the symbols what this page (http://openocd.sourceforge.net/doc/html/GDB-and-OpenOCD.html#gdbrtossupport) says, except one. This one was the “uxTopUsedPriority”. (Latest version of FreeRTOS 7.5.3) I’ve tried with an older version (7.2.0) and I found that in there. So every symbols should be there.

I think, the problem is with my FreeRTOS config, or with the compiler settings. They say the FreeRTOS and OpenOCD should work well. Has anyone had this problem? Where sould I start to check, or is there a good tutorial to read?

Thanks, Gabor

rtel wrote on Saturday, October 19, 2013:

Interesting - I never knew that existed in OpenOCD. However, it seems it is out of date as uxTopUsedPriority was removed from the kernel a while ago on the grounds that it had been obsolete for some time.

Is there anybody that can update the OpenOCD code to fix that?

In the mean time, if you are using Eclipse, you can use the Eclipse StateViewer plug-in for FreeRTOS (which is now maintained by WITTENSTEIN: http://www.highintegritysystems.com/down-loads/stateviewer-plug-in/

Regards.

csorvagep wrote on Saturday, October 19, 2013:

Thanks, I’ll check that as soon as I get the email.

The problem with the uxTopUsedPrioirty is not that big. This should work with an older version. After that, I’ll send them a mail about that.