IAR and uIP

nobody wrote on Friday, November 17, 2006:

I have downloaded FreeRTOSV4.1.2 and even 4.1.1 and keep experiencing the same error, with IAR 4.30A (Using Kickstart4.0) gives the same error message when first opening the project:

Broken Links Detected

A backup copy will be made

Here are the error messages:

LOAD: Configuration ‘Flash Debug’ in the project ‘rtosdemo’ contains broken options for tool ‘XLINK’:

  The format of this file is not supported by this version of the workbench.  It appears to have been written by a newer version of the workbench.

Diagnostics: ‘Settings ‘XLINK’: unsupported version - 18’.

  Options for ‘XLINK’ will be set to default.

  Creating backup of original project file.

LOAD: Configuration ‘Flash Release’ in the project ‘rtosdemo’ contains broken options for tool ‘XLINK’:

  The format of this file is not supported by this version of the workbench.  It appears to have been written by a newer version of the workbench.

Diagnostics: ‘Settings ‘XLINK’: unsupported version - 18’.

  Options for ‘XLINK’ will be set to default.

WTD: Unavailable option selection: ‘Atmel AT91SAM7X256’.

WTD: Changed to default selection: ‘None’.

I have built a couple of the other projects just to check IAR and all build OK.  Any light you can shine would be greatly appreciated.

rtel wrote on Friday, November 17, 2006:

Please download the latest version (4.40A?) from IAR - the KickStart is a free download.

The project file format seems to change with annoying regularity.  You will probably have to install a clean version of FreeRTOS.org from the zip file download also.  Using an older version of Embedded Workbench to open a project created from a newer version has in the past resulted in the project being clobbered - with all options being lost.

Let us know if this fixes the issue.

Regards.

fabtor wrote on Wednesday, November 22, 2006:

Hi,

I compile uIP with gcc and i enable the UIP_LOGGING for debugging with serial port.

When i connect to my board with ethernet cable, i receive the follow error:

"ip: invalid version or header length"

Why? Can you help me please?

Thanks!

nobody wrote on Wednesday, November 22, 2006:

I suspect the structure packing is not correct.  You have to use __attribute__ ((packed)).  There was a post on the uIP mail list about this about a week ago you might want to look it up.