Git cloning RP2040 help / pointers needed

Hi All, new here so apologies if I’m posting incorrectly, I’ve searched for RP2040 and found nothing…

I’m having trouble with cloning FreeRTOS-SMP-Demos, I’m looking to use FreeRTOS on an RP2040. I’m working on a Raspberry Pi 4. I tried adding links to explain but that’s not allowed. Basically I followed the instruction on Git to clone (removed chars that make this a link)

git clone http s github com FreeRTOS FreeRTOS-SMP-Demos git --recurse-submodules

and I get errors:


Cloning into ’ home pi FreeRTOS-SMP-Demos FreeRTOS Source’…
git@github com: Permission denied (publickey).
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

and a few more lines

If I leave off the " --recurse-submodules " there’s fewer lines displayed and no errors, but when I then " git submodule update --init --recursive" I get the error:
“fatal: not a git repository (or any of the parent directories): git”

I also tried the SSH link using Putty, no joy.

Any clues or pointers to where I’m going wrong would be most welcome,

Thanks
Ric

Just to confirm there does seem to be an error - maybe with a submodule pointer. Will look into it and report back when its fixed.

May have a fix…
The “home/pi/FreeRTOS-SMP-Demos/FreeRTOS/Source” folder was empty so I followed the link in Git to the “FreeRTOS-Kernel” where there’s a link for HTTPS cloning it, and did so.

I ended up with these side-by-side
/home/pi/FreeRTOS-Kernel
/home/pi/FreeRTOS-SMP-Demos

I then simply copied the contents of /FreeRTOS-Kernel to the empty source folder in the demos.

The submodule link was for SSH which requires that you have a certificate configured with github. I fixed the link to use HTTPS. Thank you for reporting the issue.