Not a git repository


I am working on AWS FreeRTOS, and downloaded the project from aws console.

I am following this guide for esp-idf v4.2.

So for ubuntu I start like below :

  1. sudo apt-get install git wget flex bison gperf python3 python3-pip python3-setuptools cmake ninja-build ccache libffi-dev libssl-dev dfu-util command.
  2. sudo usermod -a -G dialout $USER
  3. vendors/espressif/esp-idf/

But the third step give me error.

Not a git repository, can anyone help me out here.


Hi @abhibhatia98 ,

It will be helpful for us to debug the issue if you can post the exact error message that you are getting after the third step.


seems like I do something wrong, now it is sorted.


Thanks @abhibhatia98 for reporting back that the problem is solved.

Readers who encounter the same problem might be curious how you have solved it, that is one of the purposes of a forum.

But the third step give me error. “Not a git repository”

Let me guess: you had installed the enitre source tree but not the .git and .github directories? In other words, you were not working in a cloned repo?