FreeRTOS compilation for LM3S6965 rev C

militant_daos wrote on Sunday, December 07, 2008:

There is an issue with FreeRTOS compilation for LM3S6965 rev C board using IAR Embedded Workbench.

In instructions for compilation we may see such things: “…Select ‘Rebuild All’ from the IDE ‘Project’ menu. The project should build with no errors or warnings”, but when I have done this, I have got three warning messages from linker:

1." Warning[Lp012]: no sections with name DATA_ID included - special symbol DATA_ID$$Base (referenced from D:\
DEVELOPMENT\FreeRTOS\FreeRTOS\Demo\CORTEX_LM3Sxxxx_IAR_Keil\Debug\Obj\startup_ewarm.o) will be zero "

2. -"- DATA_I$$Base -"-
3. -"- DATA_Z$$Base -"-

Driverlib was added to project before compilation,
and references to RIT12x64x4* in main() were corrected.

Then I downloaded compiled project to the board - and
it didn’t work at all (the screen stayed blank, breakpoint wasn’t set to
main() also, and debugging wasn’t available).

I use IAR Kickstart 5.0.

Can You suggest me any solutions for this "murky" issue?

Thaks in advice.
(I’m sorry for my bad English :slight_smile:

rtel wrote on Sunday, December 07, 2008:

I tried a clean build using Embedded Workbench 5.11 and did not get any warnings, so can only assume that they are due to the driverlib library.

You say that driverlib was added to the project before building, but it should have been included in the project already.  Did you just update it?  (it is included in the project from the FreeRTOS\WorkingCopy3\Demo\Common\drivers\LuminaryMicro\IAR directory)

I would expect you to have to change the display driver functions for a Rev C board (as you say in your post), but even with the wrong display functions you should still be able to hit main().

Can you see what is being executed when you pause the debugger?


militant_daos wrote on Sunday, December 07, 2008:

Well, I tried to build FreeRTOS without changing anything.
Compilation was successful, but linker failed.
It throwed 35 errors like “No definition for XXXX referenced from YYYY” and that three warnings about segments that I’ve mentioned in last post.

When I added my driverlib to ‘Additional libraries’ option for linker, the project linked without errors, but it still doesn’t work.

The next strange thing: there are no debug commands available when project downloaded to the board, except ‘Break’ and ‘Stop session’ (the same is for software debugger).

When I stop execution (‘Break’) the PC in disassembly window always points to undefined instruction, so I’m not able to observe what is executed.


rtel wrote on Sunday, December 07, 2008:

Very curious.  Do you know the version of the compiler you are using?  I know you said it was KickStart 5, but 5 point what?

Sometimes with IAR, if you open a project with a version lower than the version used to create the project it will silently loose a lot of project settings, preventing the code from compiling without giving any clue as to what happened.  Maybe this is the problem?

Also, are you sure the code is being downloaded.  Under the project options, Debugger category, Download tabs, is "Use Flash Loaders" checked?

Can you try adding the version of driverlib that comes with FreeRTOS into your project, rather than your own copy.  I gave the path in my previous post.


militant_daos wrote on Sunday, December 07, 2008:

My IAR version is 5.20

About driverlib.
I’ve explicitly added original driverlib (driverlib.r79) to the project, but the linker throwed an error that driverlib.79 is neither a library nor an archive file.

‘Flash loaders’ option is checked.

rtel wrote on Sunday, December 07, 2008:

The file you should have included is FreeRTOS\WorkingCopy3\Demo\Common\drivers\LuminaryMicro\IAR\DriverLib.a


militant_daos wrote on Monday, December 08, 2008:

Finally, the problem was solved. I’ve downloaded FreeRTOS 5.11 and it has been built without any problems.
I think, there is a bug in IAR project manager: most of settings are lost when the project is converted from old format to the new one
(yesterday I tried to build FreeRTOS 4.5, which was on the supplementary CD shipped with the evaluation board).

Now all things are OK.
Thank you very much for your help.

Best regards.