Demo STM32F103_IAR Schedular won't start

rklan wrote on Saturday, July 24, 2010:

Hello,
I’m new to using the Free RTOS OS, and I tried to adapt a demo to my board.
I followed the guidelines found on the website, and tried to flash a LED.
When I use an ordinary main(), it works, So I know the HArdware is OK.
But when I replace the main, by the original main, from the demo. I’t doesn’t work.
I commented aal the extra tasks, so only the FlashLEDTask was there.
How doe I chek if the systemtick is OK.
Any other things I should check?

davedoors wrote on Saturday, July 24, 2010:

Have you set up the vector table to include the interrupts that FreeRTOS needs? Systick, PendSV and SVC?

Start with one of the supplied demos, then it will be ok.

rklan wrote on Saturday, July 24, 2010:

I don’t think so…
Thanks !!
I go check it out.
The demo, on the webstie is not complete… it even doesn’t do any rcc configuration.
For now, I have  to go partying, but I’ll look at it, very soon.
Thanks!!!!
Do you have an example of the setup of interrupts?

Regards 

rtel wrote on Saturday, July 24, 2010:

As far as the demos are concerned - as far as I know they all set up the clocks to be correct as per the demo and kernel configuration.

Regards.

rklan wrote on Sunday, July 25, 2010:

Thanks man! I Didn’t setup the vetor table right. Now it works like a charm!!\
This happened because my hardware uses a LED on port G, while the demo only supports until port E (the ST-Firmware lib was from 2007) So I decided to use a brand new FWLib… and unfortunately, it had a slightly different structure. And here, I used the new, and original vector.c.  So that was the problem.

Thanks for the kint, you saved me a whole day, and som hedaches.

rklan

oattypotter wrote on Friday, October 01, 2010:

Please help me to setup the vector table. I never use this Microcontroller before.
Thank you.

Regards