Changing the frequency from 48MHz to 112MHz

when I change configCPU_CLOCK_HZ from 48MHz to 112MHz the tasks have more delay.
I use configTICK_RATE_HZ as 1000Hz.
I see the time that the task took to perform has a delay twice if I set it to come every 1s
I see that it come every 2s and so on
I need to change the frequency of the CPU clock without causing a delay in tasks
I use s32k142 board

Is it possible that the MCU clock setup code of your application doesn’t take configCPU_CLOCK_HZ into account properly ?
You should verify that the clock (PLL etc.) HW setup is working correctly also with changed configCPU_CLOCK_HZ.

first, thank you for your reply.
I think that you are right but how to verify it ?
can you tell me the steps to do that ?

There must be an init function doing that. Or do you use MCUXpresso ? Then I guess you can configure it somewhere. I’m not familiar with it.

This is a Cortex-M4, I think, so by default the port layer should use the configCPU_CLOCK_HZ definition to set the correct tick frequency - but that assumes the SysTick clock is clocked at the same speed as the CPU. That assumption holds in most, but not all cases. Where that is not the case you can instead set the configSYSTICK_CLOCK_HZ constant in FreeRTOSConfig.h as per

You should also check the clock speed you think you are setting is the actually clock setting you achieve - it is possible the problem is in the actual clock configuration deviating from the intended clock configuration.