vTaskResume & vTaskSuspend

brenodee wrote on Saturday, January 26, 2008:

Hi, I got undefined reference error from compiler when tried to use those commands regardless of having configured the INCLUDE_vTaskSuspend to 1 in RTOSconfig file. Is there anything else to be configured?

Best wishes!!!

brenodee wrote on Saturday, January 26, 2008:

I fixed the previous error doing a make clean. But the command is not working! I do a vTaskSuspend(xHandle) but it doesn’t stop the thread!!!


rtel wrote on Sunday, January 27, 2008:

I presume you are using GCC?

Using an unmodified GCC demo I tried adding vTaskSuspend( NULL ); within a task and as expected it failed to link.  Then I changed the definition INCLUDE_vTaskSuspend to 1 in FreeRTOSConfig.h to include the file, and then the project compiled and linked without any errors.

From the files you sent I can see that you have already set INCLUDE_vTaskSuspend to 1 so I don’t know why your code would not build.  Have you made any other changes?