STM32L4 Discovery Kit - Cannot connect to MQTT broker

Bread wrote on November 07, 2018:

My board cannot connect to MQTT broker.
So I tried to remove USE_OFFLOAD_SSL
Let me know where USE_OFFLOAD_SSL is defined

Bread wrote on November 08, 2018:

Why does deleting USE_OFFLOAD_SSL cause the program to work?

Gaurav-Aggarwal-AWS wrote on November 08, 2018:

When USE_OFFLOAD_SSL is deleted TLS is done in Software on the main MCU as opposed to offloading it to the WiFi module. As I mentioned before, you should not need to delete USE_OFFLOAD_SSL in order to make the demo work.

Would you please share the logs without removing USE_OFFLOAD_SSL to help us better understand the problem.


Bread wrote on November 10, 2018:

Is the Wi-Fi module that is not updated unable to perform SSL properly?

what is the reason?

Gaurav-Aggarwal-AWS wrote on November 12, 2018:

Some issues have been fixed in the WiFi module and therefore it is necessary to update the module’s firmware to successfully connect to AWS IoT. Offloading SSL to the WiFi module results in better performance and smaller memory footprint. It is therefore recommended to keep USE_OFFLOAD_SSL enabled.


Bread wrote on November 13, 2018:

Very Very Very Thank you so much
i never forget your help