problem run PC app

nobody wrote on Wednesday, May 09, 2007:

In demo PC application,Main.c i have modified with very basic things like crate task and in that task entry function send mess in queue and receive mess , but after some point of time it gives error. this dialog is appear.

------------------------
16 bit MS-DOS Subsystem

C:\FreeRTOS\Demo\PC\rtosdemo.exe
The NTVDM CPU has encountered an illegal instruction.
CS:1044 IP:a72c OP:ff ff 00 00 4d Choose ‘close’ to terminate the application

             close          Ignore
---------------------------

rtel wrote on Thursday, May 10, 2007:

Which OS are you running the demo under?  DOS, Win2K, XP, etc.  There may be a problem accessing the parallel port if you are running XP.

Regards.

nobody wrote on Thursday, May 10, 2007:

I am using Win XP, PC demo application is for 16bit DOS and using owotcom compiler.
If i want to run on intel processor & XP OS what i can do? and without ERROR.
Thanks

rtel wrote on Thursday, May 10, 2007:

You could either boot a PC into FreeDOS, using a floppy disk (this is what I do), or run it on an Win2K or lower machine - then you should be able to run the whole system.

To run it on XP you will probably have to remove anything that attempts to write directly to the hardware. 

Try this:

+ In main.c, commount out the lines: 
—vParTestInitialise()
—vStartFlashCoRoutines( mainNUM_FLASH_CO_ROUTINES );
—vStartComTestTasks( mainCOM_TEST_PRIORITY, serCOM1, ser115200 );

The first two write to the parallel port, the last writes to the serial port.  If the code executes like this you will get some warnings on the display that the COM test tasks are failing (because the line that creates the tasks has been commented out).

The code will still attempt to write to the hardware timer, which may generate the same error. 

Regards.

rtel wrote on Thursday, May 10, 2007:

Actually - I just tried running it on an XP machine and it executed without any problems.  The error must be being caused by something else.  I should ignore my last post.

Regards.

nobody wrote on Thursday, May 10, 2007:

In demo main.c : It is giving error "Com test count unchange! " Beacause of no loopback connector

I modified this main.c
But in  my main.c only this things are there ,all i deleted

sQueuecreate
xTaskCreate
TaskstartScheduler

Task entry function
used xQueuesend and xQueuerecive

that’s all.

I have given print statement , through i can see queue recive the mess.
give mess for nearly 1 sec,
then it gives error

Compiling successfully.
While running it is giving error: that is in 1st message of mine

nobody wrote on Friday, May 11, 2007:

Is anybody have answer of this? please let me know. it is very urgent.
Thanks