PIC32 Demo Comtest Tasks not running!

maiorfi wrote on Thursday, June 23, 2011:

Hi.

I just tried PIC32 demo on an Explorer 16 Board with PIC32MX7 PIM module.

All tasks work well, but only if i comment out com test task initialization:

vAltStartComTestTasks( mainCOM_TEST_PRIORITY, mainCOM_TEST_BAUD_RATE, mainCOM_TEST_LED );

It seems that after creating such two tasks (rx and tx tasks), the scheduler isn’t able to switch any task.

What’s more, code inside such two tasks is never executed.

Any suggestion?

rtel wrote on Thursday, June 23, 2011:

Version 7 of FreeRTOS updated the port layer slightly to work with the compiler that Microchip released a few weeks prior to that.  At that time I checked the code on the Explorer 16 and it worked fine.  The comtest tasks need a loopback connector to be fitted in order to function without flagging an error, but the tasks should run even without the loopback.

Regards.

maiorfi wrote on Thursday, June 23, 2011:

Changing the PIM and replacing PIC32MX7 with a PIC32MX3 solves the problem.

What could it be that is so different between two models?

Thanks!

rtel wrote on Thursday, June 23, 2011:

The 7xx series is much newer than the 3xx series, and has several architecture enhancements/changes.  For example, the 7xx needs an extra #pragma definition in the configuration file, and won’t work without it, while the 3xx won’t work (or won’t compile) if the parameter is present.

There has been discussion on this forum before about the UART on the 7xx parts.  The demo in the FreeRTOS download does not target the 7xx parts, although the examples that come with the FreeRTOS book do (although the book examples don’t use the UART).

Regards.

matkey wrote on Tuesday, October 11, 2011:

Hi all,

Im looking at the same problem. Im using the PIC32 Starter Kit (360) and the Starter Kit 2 (795). Fine on the 360 and hangs on the 795 at the ConfigIntUART2 line in serial.c (copied from the FreeRTOS demo folder)
Has anyone else managed to get to the bottom of this? Just wanted to check before I delve in……

Mat