Luminary UIP+Eclipse demo hanging

sergiosider wrote on Friday, February 27, 2009:

Hi Guys,

I am trying the FreeRTOS Luminary port demo with uIP + Eclipse, using my LM3S6965 board from Luminary.

Installed Eclipse Version: 3.4.1
Build id: M20080911-1700

Sourcery G++ lite (4.3.2), and changed the paths in Eclipse projet to reflect the correct directories (in the zip file it pointed to C:\devtools\Soucery…)

Compiled it OK, and flashed it with Luminary flash utility (could not use OpenOCD yet because it asked for Cygwin.dll or something like it that I do not have).

It worked. Except on the io.shtml page…
when I click on the "UPDATE IO" button, the state of the LED is updated but the application HANGS without any message.
Evertthing stops, even pings stopped working.

I only changed the IP address in the original source code.

Any suggestion on where to look for the problem?

Sergio P. Sider

sotd wrote on Friday, February 27, 2009:

I dont know if it works with all browsers. Had problems with some and not all.

sergiosider wrote on Friday, February 27, 2009:

Hi again…

I found the problem.

I had the CodeSourcery for Stellaris version (not the Lite one), and at first, I changed the Makefile to use it (arm-stellaris-eabi instead of arm-none-eabi)

Now, when I change it back to arm-none-eabi it worked!

I thought it should work… maybe my version is broken (not the last one)… It may explain why I have strange crashes sometimes in other applications… :wink:

Thanks anyway!

PS. Jitter is 160ns using arm-none-eabi , and was 140ns using arm-stellaris-eabi… is it a clue ?