Interrupts enabled during system init

jdabbs003 wrote on Friday, September 04, 2009:

Hello.  Our system boots, sets up the hardware, creates FreeRTOS tasks and queues, then starts the scheduler.  The intent is that interrupts are disabled until the tasks start.  However, FreeRTOS is enabling interrupts almost immediately because of the way critical sections work.

There are several ways to fix this.  But, is there a "right" way?

rtel wrote on Friday, September 04, 2009:

Most if not all ports should do the opposite to what you describe.  Which port is it you are using?