FreeRTOS with MPLAB PIC32MX upgrade from 7.1.1 to 8.2.0... system is too fast???

ulmus71 wrote on Wednesday, February 18, 2015:

Today (after 3 years working on 7.1.1) i tried to upgrade system to freertos to 8.2.0.
I am using PIC32MX with MBLAB 8… (not MPLABX).
Port uses header ‘xc.h’, i looked into it and saw that it is simply p32xxxx.h, so i have edited that.
I also change timer T1 to T5 (which i am using) all went ok.
whole freertos and port files compiled great, but…
after few moments my system hangs, but on my tft lcd i have blinking icon and it blinks about 2 times quicker. That’s all for now :frowning:
i tried to change timer to be slower (if some time dependences would be) but it behaves the same: hangs with blinking icon 2 times faster than usual.

Anybody has experience with freertos 8.2 and mplab 8xx not mplabx? is there anything i forget or didnt know to change?

p.s. to change timer t1 to t5 i set proper 2 definitions and edit port.c changing proper registers to suits timer T5 of course.

tlafleur wrote on Wednesday, February 18, 2015:

I run 8.2 on MX and MZ under MplabX, all work well…
fyi… --> Harmony is a work in progress…

Tom Lafleur

rtel wrote on Wednesday, February 18, 2015:

Assuming the configuration of the clock is identical between the two versions, and that is your own code anyway (the tick is being set outside of the FreeRTOS code), then I cannot think of any reason why switching from V7.x code to V8.x code could effect the clock’s speed (as the timer configuration is not in the FreeRTOS code). What else has changed? Compiler version, library version, header files, etc.?

Regards.

ulmus71 wrote on Wednesday, February 18, 2015:

Thanx, i think it needs investigations. Tomorrow i will get old mplab port, only new 8.2 freertos and check again.
p.s. i have only changed freertos and port sources, nothing else (i still working on my system and compile it to include new updates and all is working great) today i just did git fork to update freertos, nothing more.