RTOSDemo of the MPLAB X have problem

fabiomedeiros wrote on Friday, March 06, 2015:


I have used FreeRTOS V6.0.0 with Mplab 8.92 and I don´t have problem. Now, I need design new project with PIC32MZ family and I want to use FreeRTOS V8.2. So, I made the download of file FreeRTOSv8.2.zip and compile Demo project at the MPLABX. The compile worked. The problem happened when I tried to simulate the program. The simulate always stop at the function _general_exception_handler. I didn´t change anything at project. So, I guess the program should run well. What is wrong with RTOSDemo project for MPLAB X?

I have used Mplab X 2.30 and my compiler is XC32 v1.34

I get the _excep_code= EXCEP_AdEL(0x04)

rtel wrote on Friday, March 06, 2015:

Unless Microchip have changed something very recently it is a known issue with the simulator that it cannot simulate a FreeRTOS application. I’m not sure of the root cause, but basically it is not a “complete” simulator - maybe more of an instruction set simulator.