FreeRTOS Simulator - Eclipse+MingW - Crashes

pmtwiss wrote on Monday, January 07, 2019:

Hi Everyone,

New to SourceForge, and new to FreeRTOS. I am trying to use the MingW simulator provided by the RTOS zip (under demo). Tried to run the simulation of blinky, the more basic demo, (main_blinky.c), by setting:


Not sure why that text paste so huge … sorry.

Anyways, I tried on 2 different machines, and when I only, simply set this definition to 1, it crash. I’m doing nothing else.

NOTE: When this bit is szet to 0 (Test Demo), it runs perfectly.

Is there something I am missing?

System Info:

  • Windows 10 64 (fully updated)
  • Eclipse, build 2019-12
  • FreeRTOS v10.1.1
  • Eclipse set up with MingW
  • I can write C-code and compile and run just fine (not system related)

Any help would be great, I’d like to start with the blinky as the test version is crazy as hell and I am not ready for that.

[SEE ATTACHED IMAGE] - one one machine, the other just totally crash eclipse


rtel wrote on Monday, January 07, 2019:

Apologies for this. It is because the trace recorder library is only
initialized if mainCREATE_SIMPLE_BLINKY_DEMO_ONLY is set to 0, but still
used even when it is set to 1. I have fixed this here:
by moving the trace recorder library initialisation up so it is
initialized no matter the mainCREATE_SIMPLE_BLINKY_DEMO_ONLY setting.

pmtwiss wrote on Monday, January 07, 2019:

Hi Richard,

Thanks for your fast response my friend! In the comments it states the tracer is optional, but looks like it’s required. I’ll read on the tracer, there is a link. I love how well this code is commented.

Thanks again

pmtwiss wrote on Monday, January 07, 2019:

I made the change and it fixed the issue.


(I don’t see the resolved/solutions button here}