explorer 16 -- fail #2

kingsob wrote on Monday, June 02, 2008:

I programmed my explorer 16 (I tried both the dsPIC33 and the PIC24 plug in modules) and everythign seemed to go well… all the led’s are blinking as described in the docs… however on the display, all it says is FAIL #2 after the www.FreeRTOS.org line dissipears.

I can’t seem to find any information on what FAIL #2 means. Any information would be greatly appreciated.

Derek

picmeup wrote on Monday, June 02, 2008:

Look for FAIL #2 in main.c. It is result of comtest task error. Do you have loop back on your com port?

kingsob wrote on Monday, June 02, 2008:

how would i check if i have a loopback?

i havent changed anything on the explorer board, just programmed it. does the board need to be connected to my computer with the serial port?

kingsob wrote on Monday, June 02, 2008:

i plugged in the serial cable, and i see it spamming A-Z… but still get fail #2  :frowning:

kingsob wrote on Tuesday, June 03, 2008:

ooo i get it

* Creates two tasks that operate on an interrupt driven serial port.  A
* loopback connector should be used so that everything that is transmitted is
* also received.  The serial port does not use any flow control.  On a
* standard 9way ‘D’ connector pins two and three should be connected together.
*

thx