Developing from lwIP Demo with Rowley v1.7

ogradyg wrote on Friday, October 05, 2007:

I am working on a project using an Atmel AT91SAM7SE, Crossworks v1.7 and JLink JTAG interface.  I have my own hardware that works without the RTOS as well as an Atmel AT91SAM7X-EK board.

First I tried building a new SAM7SE application and bringing in the FreeRTOS files and settings but I would run into a Data Abort within a few ticks.

Then I tried to work with the demo application on the AT91SAM7X-EK board but I couldn’t get access to the CPU for downloading through Crossworks. Crossworks reported that it couldn’t stop the CPU - in both release and debug configurations.  I have been able to download the demo using the Atmel SAM-BA tool and it works (compiled with Crossworks). 

I tried to create a new project within the demo solution so as to duplicate as many settings as possible.  This application can be loaded and stepped through with Crossworks but it crashes almost immediately, the same as my initial attempt.

Has anyone been able to get this port to work with Rowley v1.7?

Has anyone done a SAM7SE port?

davedoors wrote on Friday, October 05, 2007:

Regarding the SAM7X EK and Rowley.  Look at the setting for the J-link (target properties).  If adaptive clocking is selected, try unselecting it.  If it is already unselected, try selecting it.  I can not remember what the setting should be but I do remember have a similar problem when it was set wrong.