coreMQTT-Agent: How to upgrade from older version

My application is based on coreMQTT-Agent version v1.1.0 (Actually 3 changes above it).

The coreMQTT version that come with this agent version (as a submodule) is v1.2.0.

The application is working fine with those versions but now I have an updated HW and I want to create an update project for this HW that will basically run the same application but if possible I would like to upgrade the versions of the libraries I’m using.

I first tried to use latest versions of those libs by cloning the repo and use v1.2.0 of the agent and v2.1.1 of the MQTT but the application failed (I see that TransportInterface_t have new member - writev and it is not initiated).

As I don’t want to mix the bring up effort of the new board with doing also application changes I tried to downgrade the versions of the two libs but I failed to do it.

My questions are:

  1. Is there a porting guide or any other guiding that can help me resolve this new version issue without too much effort?

  2. If the answer to 1 is no then how should I downgrade the versions? I did this and failed:

  • git clone of coreMQTT-Agent.git
  • git submodule update recursive
  • for coreMQTT - git checkout v1.2.0
  • for coreMQTT-Agent - git checkout v.1.1.0

but on the last action I get an error:

fatal: not a git repository: …/…/…/…/…/…/.git/modules/source/dependency/coreMQTT/modules/test/cbmc/aws-templates-for-cbmc-proofs
fatal: could not reset submodule index
error: Submodule ‘source/dependency/coreMQTT’ could not be updated.
Updating files: 100% (129/129), done.
fatal: not a git repository: test/cbmc/aws-templates-for-cbmc-proofs/…/…/…/…/…/…/.git/modules/source/dependency/coreMQTT/modules/test/cbmc/aws-templates-for-cbmc-proofs
fatal: ‘git status --porcelain=2’ failed in submodule source/dependency/coreMQTT

Any help will appreciated,

Here is the migration guide - coreMQTT/MigrationGuide.md at main · FreeRTOS/coreMQTT · GitHub

Use the following git command:

git clone --branch v1.1.0 --recurse-submodules git@github.com:FreeRTOS/coreMQTT-Agent.git
1 Like

Thank you @aggarg !
The two answers really helped