Zybo lwIP Implementation

troythompson wrote on Monday, February 22, 2016:

Hi, I was wondering if there have been any lwIP demos or other implementations posted for Zybo. I have searched around but have been unsuccessful in my attempt to find one. If anyone knows of one, could you please post it here or a link to it?

rtel wrote on Monday, February 22, 2016:

The Xilinx projects are actually three projects.

First there is a hardware project which describes what hardware is
available on the board.

Next there is a BSP project (Board Support Package) that is
automatically generated from the hardware project, so you end up with a
library of drivers specific to the hardware platform.

Finally there is the application project. The application project has a
dependency on the BSP project, but as the BSP project is generated from
the hardware project, the application project has no dependency on the
hardware (assuming you are not trying to use a peripheral which
physically does not exist on the hardware).

Therefore the FreeRTOS projects provided should run on the Zybo board
provided you have a hardware project for the board - which presumably
you do.

For example, our FreeRTOS+TCP project runs on both the ZC702 and
MicroZed board because we supply a hardware project for both - the
application is identical in both cases - therefore it will presumably
also run on your board. See

troythompson wrote on Monday, February 22, 2016:

I found in the the zip the application project, bsp project, and hw project for the zc702. I tried just taking the application project and pairing it with a bsp project and hw project I made for the zybo based on the zybo base system design. I couldn’t even get the basic blinky led function to work. Is there something else I need to do besides just referencing the bsp from the application project?

rtel wrote on Monday, February 22, 2016:

The way I would do this would be:

  1. Import the hardware project.
  2. Generate a BSP project from the hardware project (using the Xilinx
    SDK menus).
  3. Only then import the application project.

If you are wanting to blink and LED then check the IO pin being toggled
is correct for the hardware. The application code probably just toggles
a GPIO directly, but the LED won’t necessarily be on the same GPIO.

troythompson wrote on Monday, February 22, 2016:

Are there any supported libraries that are recommended to include in the bsp?

troythompson wrote on Monday, February 22, 2016:

I tried including all of the support libraries available I’m getting a ton of errors such as:
14:59:06 ERROR : (XSDB Server)ERROR: [Hsi 55-1545] Problem running tcl command ::sw_xilpm_v1_0::generate : Error: Processor type ps7_cortexa9 is not supported

while executing

“error “Error: Processor type $proctype is not supported\n””
(procedure “::sw_xilpm_v1_0::generate” line 30)
invoked from within
“::sw_xilpm_v1_0::generate xilpm”
ERROR: [Hsi 55-1442] Error(s) while running TCL procedure generate()
ERROR: [Hsi 55-1450] Error: running generate_bsp.

rtel wrote on Monday, February 22, 2016:

From the error message it sounds like you are using a hardware platform
that doesn’t include a Zynq. Can this be the case.

Note - at this point, this is not a FreeRTOS issue, but an issue using
the tools. Perhaps the board vendor can provide what you need for the


troythompson wrote on Tuesday, February 23, 2016:

Ok so I compared my created bsp to the bsp included with the ZC702 demo. The bsp for the ZC702 demo includes no support libraries so I removed them all from the bsp I created from the zybo hw platform and it builds without errors. However, when I run just the simple led function in the ZC702 demo application, I get no response from the zybo. Where do I need to change pin references? Or is that not the problem?