Windows Port Issues

turtle-beach wrote on Wednesday, November 13, 2019:

I have just gone through the exercise of getting the FreeRTOS_Plus_TCP_and_FAT demo working, but only after stumbling on some posts from 2018 that suggested attempts to access the RTOSDemo application need to be made from a different computer on the same network. Yet all of the documentation (tutorial steps) either state or imply that ping, and ftp access using FileZilla should work on the same computer.
(1) if that is truly possible, could someone who knows how to make it work update the tutorial pages; or
(2) if in fact access needs to be from a different computer than the one running RTOSDemo, then please update the documentation accordingly.
After succesfully building the project in VisualStudo 2019 with no compilation or build errors out of the box, following what appeared to be accurate step by step instructions (other than the console output listing network interfaces when I ran the demo looked nothing like the image in the instructions), it was extremely frustrating to then kill 2 hours trying to understand why I couldn’t ping the RTOSDemo.
The development environment is VS2019, W10 Pro, plenty of memory and disc.

heinbali01 wrote on Wednesday, November 13, 2019:

Hello Jack, I’m sorry to hear that you wasted so much time on finding out that you can only contact your Windows simulator from a different PC.

However, the reality is more complex: some people can and other people can not reach their simulator from the same PC.

I just ran the AWS/FreeRTOS pc demo and pinging worked fine:


Pinging with 32 bytes of data:
Reply from bytes=32 time=120ms TTL=128
Reply from bytes=32 time=13ms TTL=128
Reply from bytes=32 time=33ms TTL=128
Reply from bytes=32 time=9ms TTL=128

The responses are slow because of the way the PCAP device is polled. Nothing to worry about.
I am using Windows 10 Home and Npcap 0.9983.

I will do more investigation and testing, and report back here.

heinbali01 wrote on Wednesday, November 13, 2019:

The original 2016 release also responds to a ping from the same laptop.
I used this project:


I used this interface:

4. rpcap://\Device\NPF_{21A5AEFB-730B-42E6-9434-B807F70A11BC}
Network adapter 'Realtek PCIe GBE Family Controller' on local host

which is my LAN adapter. Make sure you also select the hardware adapter.

I am using DHCP, but ping also works with a static IP-address.

Ping also works like this:

	ping RTOSDemo

because LLMNR is enabled.

And finally, FileZilla also works from the same laptop:

Host : ( or “RTOSDemo” )
Port : 21
Encryption : Only Plain FTP (insecure)
Login type: Normal
User/Password: don’t care

At the bottom of this post you will find an attachment FreeRTOS-Plus-FAT_2019_nov_13.7z which contains the latest (non-official) release of FreeRTOS+FAT.
I recommend using the AWS/FreeRTOS release for all other libraries.

heinbali01 wrote on Wednesday, November 13, 2019:

I pressed on “Post” in stead of “Attach”.
This post will contain the most recent release of FreeRTOS+FAT. You will find some small differences with the 2016-release.

turtle-beach wrote on Wednesday, November 13, 2019:

Thank you for the quick response, and for the link to the latest sources. I did have the correct hardware adapter selected, and, to be clear, if I was not, I was ultimately able to ping/run ftp from another machine to the Win 10 machine. My last action yesterday was to download the 10.2.1 installer for sources to start fresh today; I will instead start with the source you linked to. While I’ve been away from the nitty-gritty of embedded work since the 1990s (the world was very different then,…) my first impressions of FreeRTOS are positive (early glitches notwithstanding).

Where is the attachment? Still I am not able to find the attachment

Can you please mail me that latest non-official release?

[Edit - email addresses removed as they attract spam bots]

The latest version should be that found in the FreeRTOS-Labs directory of the main FreeRTOS repo in SourceForce SVN (which is also currently mirrored into If that is not the case then please work with me to update the code there then we can ensure that is always the single source of truth for that library.

Same issue for this latest release also. Can we work on this and give a proper solution for this issue?

What does this mean? What is asking for a private key and what do you think is paid?