Web server for RTOS Demo for the Renesas Demonstration Kit for the RX62N fails

I recently set up FreeRTOS with my Renesas Demonstration Kit for the RX62N. I am running the latest FreeRTOS but startet with FreeRTOS 10.4.1 as this version has a working demo for my kit. When I plugged an ethernet cable from my PC to the board to see what pages the demo served, I saw that after a few seconds the page would indicate an error and the page would no longer load. The last time I looked the page would not load at all. I installed an addition ethernet board (test ok).
My recent Forum: FreeRTOS for the Renesas Demonstration kit (RDK) for the RX62N
Here is the code to the demo files directly to the webserver files: https://github.com/FreeRTOS/FreeRTOS/tree/V10.4.1/FreeRTOS/Demo/RX600_RX62N-RDK_Renesas/RTOSDemo/webserver

Also the demo has to demos. One is out of the build in the HEW (High Performance Workstation). For the webserver example it is main-full.c

Can this be fixed?

If I understand correctly, the webpage served by the RX62N loaded at first, but after some time of leaving the demo running, it started to fail. Is that correct?

Please send a Wireshark capture of the network traffic.

Is there visible network activity to the board at all, ie can you ping it?

I installed Wireshark and found I could not see the page load but there was network traffic to the board as shown in the Wireshark capture file. I then uninstalled Wireshark and was still not able to see the page load again other than seeing the filename in the browser index.shtml.

The Wireshark log file:

I could ping the board when the page was loaded.

What is the IP address of the board in the trace?

It is in the FreeRTOSConfig.h file at the bottom:

/* IP address configuration. */
#define configIP_ADDR0 192
#define configIP_ADDR1 168
#define configIP_ADDR2 0
#define configIP_ADDR3 200

There is no packet with the IP address in the wireshark capture you shared.

Which traffic in the wireshark capture file are you talking about here?

The IP Address is not seen in the capture file. There is however traffiic to the board. In Wireshark you see No. 1 to 119.

No. Time Source Destination Protocol Length Info
1 0.000000 fe80::f6c8:c19d:d50c:cc4 ff02::16 ICMPv6 110 Multicast Listener Report

How do you know that traffic is to/from the board?

I know that it is to/from the board because I have it connected to the Ethernet connection (mainboard). Without any connection Wireshark shows no activity in the capture window. My extra ethernet board is connected to my provider and is named ethernet2.

Your PC seems to be configured “automatically”, and as there is no router, it assigns itself an IPv4 link-local address Is my conclusion correct?

Would it be possible that you either connect both to a router, or assign a static IP-address to your laptop/PC and DUT?

For instance:

Laptop: ( static address )
RX62N: ( static address )
With a netmask of ?

And then please try ping and load a web page as e.g. ?

When you put a PCAP file in a ZIP file you will be able to attach it to you post. If not, put it on your github page again :slight_smile:


I set the ip address to the static ip address and netmask through the control panel way not setting the gateway and dns and sure enough it worked. I can continuously view the boards task stats and other things.
The Wireshark capture is in a zip file in the attachment.
RdkRx62n.zip (22.1 KB)

ping is of course no problem. Setting the ip to as per this instruction How to Set a Static IP Address left the board not working at first.

Trying to set a static ip-address in windows setting did not work at all.

I did make a print screen but the file is large (520k) so I did not include it in the zip file.

So we are fine and done!

Thank you very much.

Thank you for reporting back.