vtaskdelay blocks my task indefinitely

aeyes wrote on Tuesday, September 02, 2008:

Hi vTaskdelay API is blocking my task indefinitely .

I have inserted vTaskDelay( 1 ) ; in my code and the task gets suspended. I know that the tick ISR is getting generated still this wont work , what could be the problem ?.

ivernot wrote on Wednesday, September 03, 2008:

Have you tried whether vTaskDelay(100) works (or any number greater than 1)  -

‘1’ means 1 TICK - this is generally not useful as the time taken to enter and exiting the function may be approaching 1 TICK anyway
Try a bigger number report back.

Ivan Vernot

aeyes wrote on Wednesday, September 03, 2008:

Hi Ivan ,

Tried with 10 , still the same problem . The problem could be that I am working on the Skyeye simulator for Samsung S3C4510 processor and not the real hardware. Also, I have observed for the simulator that one tick takes a long time to elapse . I need to check on the hardware shortly.


rtel wrote on Wednesday, September 03, 2008:

If you are sure the tick is still running then check also for stack overflows.  This is the most common cause of problems.