Using atmel studio with FreeRTOS

bengtsvensson wrote on Friday, March 20, 2009:

I have done projects using winavr with the studio front end. I am starting a new project and intend to use FreeRTOS. Just to make sure the process worked with ATMega128 I fund and tried to run a simple demo that I found at
The demo used studio without external makefile and paths to the freertos package was used. Very nice but it did not work.
I got more than 30 compile errors that indicate that some files are not included. Either the instructions were incomplete or I have done something stupid (has happened before). I have compared the studio generated makefile with the FreeRTOS ATMega323 port makefile and this did not increase my understanding.

As I see it, I must either update and use the demo external makefile or pick apart the freertos package with all conditional compile options and move the files into my project. There must be a better way.

Have searched for a good tutorial on how to migrateĀ  from makefile to Studio without finding any.

Has anyone experience to share?