Unstable RTOS

per-kk wrote on Tuesday, September 25, 2007:


I have nearly the same problem as kellelein, I can ping the system only some times. In debug I can see packages received, and packages put to the write buffer, but nothing happens.

I use same HW (keil evaluation board ver 3.1) and Rowley software ver. 1.7, and web demo version 4.5.0.

We like to use the FreeRTOS but it must be stable, we can’t live with a system only work some times. I don’t know about it’s the RTOS, uIP stack, the HW, but help me please.


davedoors wrote on Tuesday, September 25, 2007:

I think the FreeRTOS port is solid and suspect your problems relate to the processor.  There has been a lot written on the LPC2000 Yahoo group about the LPC23xx parts.  I think NXP have had to rework the die and are just in the process of ramping up production again with parts that actually work.

The FreeRTOS port is used on many different ARM7 parts as does SafeRTOS and they are all basically the same as far as the RTOS goes.  It seems to be just the LPC2368 that has problems.

per-kk wrote on Thursday, September 27, 2007:


OK, On NXP site I found information about LPC2368 rev "-" and rev "A", I use a rev "-", and a Keil MCB2300 version 3.1. Anyone use this configuration?

I like to use FreeRTOS but it look like it can’t run on my hardware.

If I start my application in ARM Flash Debug mode it can’t RUN. Only in ARM Flash release or THUMB Flash debug. Anyone know why? Maybe it can give a hint, why my Web application can’t run.

Best regards

rtel wrote on Thursday, September 27, 2007:

I don’t think this issue is related to FreeRTOS.org, but the hardware setup in relation to you chip.  You will most likely have the same problem if you use the same hardware setup without FreeRTOS.org.

There was a post this morning saying that if the MAM mode was set to 0 (zero) then the problems went away.  Have you tried this?

According to the information I have the issues with the LPC devices are such that the error can show up in an apparently random way, as it is due to where instructions are placed in flash.  I cannot confirm this to be the case or not myself as as luck would have it my hardware seems to work ok.


davedoors wrote on Thursday, September 27, 2007:

Like I said.  FreeRTOS is not unstable.  It is most likely to be your hardware.  A Rolls Royce will feel bumpy if you drive it over rocks.

per-kk wrote on Friday, September 28, 2007:

Ok, did you say: don’t use LPC2368 because it’s unstable ?
Which ARM7 should I use? I need 2CAN, Ethernet, USB and only 3$ and it must be stable and run FreeRTOS.

Best regards

jon_newcomb wrote on Friday, September 28, 2007:


AT91SAM7A3, although $3 is but optimistic for this part!

per-kk wrote on Tuesday, October 09, 2007:

Now I have changed my LPC2368 rev - to a LPC2368 rev A and now the WebProject work. I also changed PINSEL2 = 0x55555555 to PINSEL2 = 0x55550555, because of the revision change.

I have another problem, when I run the WebProject and set a breakpint in a task, I can step in this task, but when I press RUN to run the program again, nothing happend. Any body know what happend.? Is it not allowed to break in a task ?

Best regards