Typo on the TCP pages

I believe the setting for ipconfigNETWORK_MTU on this page should be 586, not 576: https://www.freertos.org/FreeRTOS-Plus/FreeRTOS_Plus_TCP/TCP_IP_Configuration_Examples.html

Is so:



Hi Richard,

Perhaps I am using DHCP? If I set it to 576 I get this error message when compiling:


That is actually the largest MSS you can use, given the MTU. FreeRTOS+TCP or a peer may decide to use a smaller value for MSS.

I would recommend to use the definition of ipconfigTCP_MSS as it is, and if you want to save RAM, I would decrease ipconfigNETWORK_MTU.

DHCP is asking for a certain minimum, which depends on the number of options that are exchanged. I should check FreeRTOS_DHCP.c to see which value is better.

Thank you Hein, I think I have some studying to do. :slightly_smiling_face:

Hi Richard,

I was referring to the value for MTU, not MSS. The value shown on the web page, 576, appears to be too small if DHCP is being used.