The problem about interrupt on HT32 that a chip like STM32

guoguiwu wrote on Wednesday, February 19, 2014:

I transplant FreeRTOS to the HT32 that a chip like STM32. I want use UART interrupt to receive some data, but when the routine run to the UART interrupt routine it can not jump out the interrupt routine ,it just run the interrupt routine over and over. What’s the problem?
That a part of my config in FreeRTOS.h:
#define configUSE_MUTEXES 1

And a part of my code:
void NVIC_Configuration(void)
NVIC_SetPriorityGrouping(NVIC_PRIORITY_GROUP_3);// Preemption: 4 bits / Subpriority: 0 bits
NVIC_SetPriority(USART1_IRQn, NVIC_EncodePriority(NVIC_PRIORITY_GROUP_3, 12, 0));

xSemaphoreHandle xhighSemaphore;
void vultrasonic_Task(void *pvParameters)
char i=0;
char HDATA=0;
char LDATA=0;
u16 high;
xhighSemaphore = xSemaphoreCreateCounting( 10, 0 );
USART_SendData(USART1,0x55 );
xSemaphoreTake( xhighSemaphore, 500 / portTICK_RATE_MS );
vTaskDelay( 1000 / portTICK_RATE_MS );


void USART1_IRQHandler(void)
static portBASE_TYPE xHigherPriorityTaskWoken;
xHigherPriorityTaskWoken = pdFALSE;
xSemaphoreGiveFromISR( xhighSemaphore, &xHigherPriorityTaskWoken );
portEND_SWITCHING_ISR(xHigherPriorityTaskWoken );

davedoors wrote on Wednesday, February 19, 2014:

Presumably that is because you are not clearing the interrupt so it is immediately retaken as soon as you exit the handler. What makes you think the problem is related to FreeRTOS?

richard_damon wrote on Wednesday, February 19, 2014:

Generally the ISR needs to do the immediate actions that trigger the interrupt. That generally includes for a serial port getting the character and putting it some where. (This doesn’t apply for using DMA, but then when you use DMA, you don’t get character ready interrupts, you get DMA complete interrupts).

The ISR could put the character in a queue if the data rate is somewhat slow. For faster channels it should build up a “message” and on receipt of a complete message signal a task to process it.

guoguiwu wrote on Thursday, February 20, 2014:

If I did not use the FreeRTOS API in the interrupt routine, it display normal. But when I use the FreeRTOS API in the interrupt routine the problem came. So I think it may related to FreeRTOS.

guoguiwu wrote on Thursday, February 20, 2014:

Thank you very much! I solved the problem in your reminder!

guoguiwu wrote on Thursday, February 20, 2014:

I had solved the problem. Proof by facts, the problem is not related to FreeRTOS. It is because i didn’t get the character and put it some where. Thank you for you answer.