SettingUp Freertos in Visual Studio Code RPI Pico

Hi sorry for the inconvenience, I am having trouble setting the “FREERTOS_KERNEL_PATH” in visual studio code. I’ve been trying for quite some time to be able to configure that and nothing. I am trying to integrate the freertos smp in the raspberry pi pico, I have everything downloaded from the last version. However, I cannot include the library or the path from the project that I have. I am working in visual studio code, the problem that jumps is the following “FreeRTOS location was not specified. Please set FREERTOS_KERNEL_PATH.”
I would appreciate that you explain in detail how to add this, since I am a newbie using visual studio and cmake. Thank you for reading.

I’m not familiar with that setting, but can see where it is used in the code.

Which host operating system are you using?
What did you try setting FREERTOS_KERNEL_PATH to?

I think you need a setting similar to this, although I’m not sure what file it goes into:

"cmake.environment": {
  "FREERTOS_KERNEL_PATH": "~/pi/pico/FreeRTOS-FAT-CLI-for-RPi-Pico/FreeRTOS-Kernel"

The way I do it is, in VS, go to File, Preferences, Settings, Workspace, Extensions, CMake Tools, Cmake:Environment.

Hello I am using windows 10.
I’m still using the examples they give, but I still can’t get it to work. I’ll see if I can send a screenshot.

Maybe it’s the Cmake: Configure Environment setting. I actually have both set, which is confusing. I guessed wrong at least once.

"cmake.configureEnvironment": {
  "FREERTOS_KERNEL_PATH": "~/pi/pico/FreeRTOS-FAT-CLI-for-RPi-Pico/FreeRTOS-Kernel"

EDIT: I figured out where these are stored on my linux box. There is a little icon in the upper right of the CMake settings editor that is a link to the settings file.