Setting up a clean FreeRTOS 8.1.0 project in Xilinx SDK 2014.2

strnadp wrote on Friday, August 29, 2014:

Dear all,

I would like to kindly ask for an advice on setting up a clean project using FreeRTOS 8.1.0 in Xilinx SDK 2014.2.

I have downloaded FreeRTOS 8.1.0 and first setup the included example project using my own BSP and hw platform. Everything is running well on my MicroZed board, including LwIP. Thaks a lot!

Then I decided to create a clean “Hello World” example project and include FreeRTOS with LwIP on my own. It took a bit of time to include (and exclude) all files and include paths as in the example project but eventually everything complied without any error or warning. When running it on MicroZed board it executed only until the vPortInstallFreeRTOSVectorTable() call. The execution freezes at this point (with the same instruction being infinitely repeated in disassembly window).

Please, if that’s something commonly happening let me know how to fix it. I was suspecting some project or compiler setting I did not know about but I could not find anything after hours of trials and errors.

Thanks a lot for the new release and help,

rtel wrote on Friday, August 29, 2014:

Did you include the same FreeRTOS_asm_vectors.S assembly file and the same linker script (lscript.ld) in your project as per those used in the demo application? If you look in the linker script you will see it makes reference to symbols defined in the assembly file.


strnadp wrote on Thursday, September 11, 2014:

Thank you! It was the linker script. :slight_smile:

maniez wrote on Friday, December 19, 2014:


I have nearly the same problem than Petr, I’m using the ZC706 Board. I build a project same as Petr, include all the path and all the other stuff. I builded the projekt and run it on the ps7_cortexa9_0 core.It worked.
If I now want to run it on the ps7_cortexa9_1 core it breaks at the vPortInstallFreeRTOSVectorTable(). Does anyone know why it breaks and/or what i have to change??
I don’t know how tho program or read assembler. I tried to understand the code of vPortInstallFreeRTOSVectorTable() but i didn’t get it.

Thanks a lot for helping!!!

Best Regards

rtel wrote on Saturday, December 20, 2014:

Can you step into the vPortInstallFreeRTOSVectorTable() function and say which line it gets to, and what happens when it fails (for example, does the CPU jump to an exception handler?).