SAM3U-EK Demo Error

engmmostafa80 wrote on Friday, August 10, 2012:

There is an error in the demo project of sam3u-ek in IAR.
In file portasm.s Compilation error “Failed to open #include file 'FreeRTOSConfig.h”
Can any new know how to solve this error?

rtel wrote on Saturday, August 11, 2012:

Are you referring to the project file in FreeRTOS/Demo/CORTEX_AT91SAM3U256_IAR?  If so, I just tried building it and did not experience any problems.  Which version of EWARM are you using?

It sounds like you don’t have the path to portmacro.h set in the assembler include path settings.  Below are instructions for adding it, but it should be there already.

In IAR, select Options from the Project menu.  Select the Assembler category in the pop up window.  Select the Preprocessor tab.  In the “Additional Include Directories” box, enter $PROJ_DIR$/. to include the directory that contains the project in the search path.


engmmostafa80 wrote on Saturday, August 11, 2012:

Thank You. It works now, But I found that most of project configuration are not set in the project options. For example the in general menu, the target was not selected. It seems that I am using a different version than the version needed to run the project with no errors. I am using version 5.4 . What is the needed version to run the project?

rtel wrote on Saturday, August 11, 2012:

It is a persistent feature of IAR that opening a project with a version of Embedded Workbench that is older than the version used to create the project will silently destroy the project - and it seems that this is what has happened to you.

I think you will need at least version 6, and probably version 6.3.


engmmostafa80 wrote on Monday, August 13, 2012:

It worked perfectly with 6.3 version.
Thanks for the support.