SAM-ICE AT91SAM7X-EK FreeRTOS Debug problem

tonau wrote on Tuesday, March 10, 2009:

Hello @ all,

I tried to debug the newest version of FreeRTOS with the GNU Compiler Toolchain. The Toolchain is configured as described in James P. Lynchs “Using Open Source Tools for AT91SAM7S Cross Development” Revision C. Changes are made to the GDB commands, since the tutorial is for the SAM7S, like described on the yargato homepage.
The problem is, that eclipse isn’t possible to start the debugsession. It hangs at about 27%. I also changed the CFFLAG to - O0 to disable optimisation.
The rest of the toolchain works fine, compilation is ok and loading the program into flash via SAM-BA also works fine and the FreeRTOS port seems to work well.
Has anyone the correct settings for debug via SAM-ICE with eclipse?

Thanks a lot!


rtel wrote on Tuesday, March 10, 2009:

Can SAM-ICE be used with this setup as is?  I think you can buy some GDB interfaces from Segger.


tonau wrote on Tuesday, March 10, 2009:

Hi I testet again a little with this debug commands and the debug starts but doesn’t stop at main and normal debug operations are not possible.
# Listening for commands on this PC’s tcp port 2331
target remote localhost:2331
# Set gdb server to little endian
monitor endian little
# Set JTAG speed to 30 kHz
monitor speed 30
# Reset the chip to get to a known state.
monitor reset 8
monitor sleep 10
# Disable the watchdog and setup the PLL
# WDT_MR, disable watchdog
monitor writeu32 0xFFFFFD44 = 0x00008000
monitor writeu32 0xFFFFFC20 = 0x00000601
monitor sleep 10
monitor writeu32 0xFFFFFC2C = 0x00480a0e
monitor sleep 10
monitor writeu32 0xFFFFFC30 = 0x00000007
monitor sleep 10
monitor writeu32 0xFFFFFF60 = 0x00480100
monitor sleep 100
# Set JTAG speed in khz
monitor speed 12000
break main

Sometimes the connection closes down when i pause the debugging and sometimes it hangs and the step commands are not possible.
I used the same configuration with the test project from yargato and all worked fine.
Is there a problem in debuging FreeRTOS in RAM, because flash debugging seems not to work with SAM-ICE, together with eclipse, without an extra licence. 

Best Regards!