RUN from Flash ERROR

under003 wrote on Tuesday, December 06, 2011:

Hello everybody:

I have the same problem that another user has in other post.
I download both demos, blinky and full without any changes and I if the debugger is conected they work fine, but if I disconect the debugger, the demo doesn´t start.

I have tried using the icf of the freertos demo in another example and that example starts from flash correctly without the debugger.

so what could I do? When downloading the full demo I read the following message that is suspicious:

"Skipping flash loading pass because there is no data in the designated range: 0x10000000-0x13FFFFFF. "


rtel wrote on Tuesday, December 06, 2011:

Please keep these questions in one thread.

We looked at this today and can replicate the problem.  We then took an example project from the IAR distribution that targets the same board in the hope of looking at difference between that and the FreeRTOS project would identify where the problem was - but found that the project distributed with the IAR tools actually behaves in exactly the same way so that was no help.  Probably the FreeRTOS project used the IAR project as an example in the first place.

It sounds like your test of using the same icf file in another project discounts the icf file as being the source of the problem.  Have you also tried using the same startup code?  What was the other project you used?

I’m not sure what the solution is yet, but presume it is something to do with vector mapping and/or reset performed by the debugger being different to a real hardware reset.

Let me know if you fix it, but I hope to sort it out before the next release.