RTOSDemo - MCF52259 - no go with ethernet..

vespaman2 wrote on Wednesday, October 14, 2009:

Last couple of days, I have been struggling with the Coldfire 52259 demo, and lwip in particular. Thing is, that I cannot get the example code to work, specifically, I am stuck in the ethernet init (low_level_init(), row 425 in MCF5225x_ethernetif.c) reading from phy. I am stuck in the loop, only getting 0xffff from the fec_mii_read().

This is therefore a call out, if this is known to work.

I am using a standard 52259EVB from freescale, nothing fancy, or modified in anyway. I have the same issue with the codewarrior demo project, as my own codesourcery/gcc compiled code.

Any Ideas?



rtel wrote on Friday, October 16, 2009:

All I can say is it definitely worked when the code was released, although I have not tried it in a while.


vespaman2 wrote on Tuesday, October 20, 2009:

I am embarrassed to say that there where 2 jumpers on the demo board misconfigured out of the box, so all is well with the mii communication now.