Problems with setting esp-devkitc up

Hello everyone,

after strugeling for the last two weeks. I’ve finaly given in and i am seeking for help.
After trying the tutorial many times and looking up other peopls post on this forum, i don’t have anything working.
I have been following this tutorial:

Getting started with the Espressif ESP32-DevKitC and the ESP-WROVER-KIT on AWS

First i tried it on my windows computer and later with a linux (with which i didn’t came much further with)

The tutorial seems reasonable but without much experience with setting up programming enviroments, it is easy to get lost.

On the windows side it breaks when i use this line: -DVENDOR=espressif -DBOARD=esp32_wrover_kit -DCOMPILER=xtensa-esp32 build

I get a lot of not used and undeclared.
if you wanna see the errors, ask and i’ll post

On the linux side
i get “ command not found”
And if i use it this manner : sudo python ./vendors/espressif/esp-idf/tools/ -DVENDOR=espressif -DBOARD=esp32_devkitc -DCOMPILER=xtensa-esp32 build

I get a importerror : no module name click.

Furthermore, i have tried cmake gui. which gave a bit more hope but also gave me a lot of errors with but after changing some stuff. It gives me that ‘the following Python requirements are not satisfied’.

I know what i wrote is a bit all over the place. I have some questions ask and wondering if anyone can give a hand with this. Either by helping or giving some kind of advice. Right now i am bit confused by it all.

Following the tutorial you need to install the toolchain of ESP so you get esp-idf installed. But when you install the amazon freertos it already comes with esp-idf. so what is the point to have both and which one are you supposed to use?

From what folder do you need to run it all from ?
from /FreeRTOS or do you need to inside of the demos ?

What cmd prompt are you supposed to use?

I’ve tried to use the mingw32, but I get all sorts of problems. Like not able to find or instead of running it. It just opens it in VS code.

So I’ve been using the esp-idf prompt cmd which fixed a lot.

What would be easier to use?
In the end i want to use either vscode or eclipse for this all But first i need to get this running.
I was wondering what would be easier to do ? the Cmake way or the Idf way?
I’ve tried both and both times i didn’t get it to work. But i would like to choose one to put my focus on

I followed the getting started guide on Ubuntu 20.04.3 LTS and it works for me. Here are the commands from my history:

sudo apt-get install git wget flex bison gperf python3 python3-pip python3-setuptools cmake ninja-build ccache libffi-dev libssl-dev dfu-util
gh repo clone
cd amazon-freertos/
git submodule update --init --recursive 
source vendors/espressif/esp-idf/ -DVENDOR=espressif -DBOARD=esp32_wrover_kit -DCOMPILER=xtensa-esp32 build erase_flash flash monitor

Can you please try the same commands and let me know if they work?



Sorry for my late response.
I finally got around to try it. And with much amazement i got it working in 10-20 minutes.
The commands you provided were nearly perfect, i just needed to do some additional stuff.
For example before the last four commands, i did ‘sudo -s’ to be able to have the privileges to work on the next commands.

But it was a lot easier on linux than on windows.
Thanks a lot, I now need to figure out how the code works and where i am supposed to program.