Problems with RX600_RX62N-RSK_GNURX RTOSDemo

sbrauss wrote on Thursday, February 16, 2012:

Hi all,

I compiled the RTOSDemos RX600_RX62N-RSK_GNURX  and RX600_RX62N-RDK_GNURX from FreeRTOS Release V7.1.0. The RDK version runs fine, but with the RSK I have, ethernet communication does not work. I played around a while but so far, had no success.
Is there someone that can confirm that the V7.1.0 demo code runs fine on the RSK? - I asked myself if I maybe have a broken board…

Thank you!

rtel wrote on Thursday, February 16, 2012:

Well I can say that when the code was added to the distribution it definitely worked.  It is possible that the GCC version has changed since, although it is unlikely that that would have caused a problem (but not impossible).

Is it just the Ethernet that is not working?  Are the LEDs flashing OK?


sbrauss wrote on Tuesday, February 21, 2012:


Yes, it was only Ethernet not working. RTOSDemos RX600_RX62N-RSK_GNURX runs fine, it was my fault, I found the reason today.

Thank you!

rtel wrote on Tuesday, February 21, 2012:

Please also post the reason for it not working - so other forum users can benefit from your experience.  Thanks.


sbrauss wrote on Wednesday, February 22, 2012:

I added nothing, as it simply was stupidity, and because it takes longer to explain… :wink:
But, here is the long version:
- Used RTOSDemos RX600_RX62N-RDK_GNURX, worked fine, added own code and made some changes
- diff between RTOSDemos  RX600_RX62N-RDK_GNURX and RTOSDemos RX600_RX62N-RSK_GNURX, incooperated them in my code to make it run on RSK and RDK
- Result: Ethernet on RSK did not work in my code, anything else runs fine
- Took original  RTOSDemos RX600_RX62N-RSK_GNURX, compiled it, found Ethernet not working
- Looked into he code, but found nothing
- Wrote to this Forum
- took Renesas RSK sample code because I thought that maybe my RSK is broken, but Ethernet runs fine with it
- Looked into my code, found that some port setup lines added by me in hwcondig.c were wrong for RSK, Ethernet now runs fine on RSK in my code
- Found the reason for the “non-working” RTOSDemos RX600_RX62N-RSK_GNURX: I had changed the network address in my code and still “ping”-ed on this address…

Best regards,