Problems compiling Stellaris demo

mjonir wrote on Friday, November 16, 2012:


I’m have problems compiling the Stellaris demo (exact target is EK-LM3S2965) using Eclipse, as described here:

I have 2 problems:

1) When I try compiling, I get these errors:

cc1: error: unrecognized command line option ‘-mthumb’
cc1: warning: ‘-mcpu=’ is deprecated; use ‘-mtune=’ or ‘-march=’ instead
main.c:1:0: error: bad value (cortex-m3) for -mtune= switch

Which options should I use? Or can I remove these safely?

2) arm-none-eabi-gcc -c -g -I . -I …/…/…/Source/include -I …/…/…/Source/portable/GCC/ARM_CM3 -I …/…/Common/include -D GCC_ARMCM3_LM3S102 -D inline= -O0 -Tstandalone.ld -D PACK_STRUCT_END=__attribute\(\(packed\)\) -D ALIGN_STRUCT_END=__attribute\(\(aligned\(4\)\)\) -D sprintf=usprintf -D snprintf=usnprintf -D printf=uipprintf -I …/…/Common/ethernet/uIP/uip-1.0/uip -I ./webserver -ffunction-sections -fdata-sections -I …/…/Common/drivers/LuminaryMicro main.c -o main.o
main.c:115:19: fatal error: stdio.h: No such file or directory

The " …/…/…/Source/include" option should point to the correct directory. I even tried adding a -I option with an absolute path to this, it didn’t change anything.

Would you have any idea what’s causing this error?

Thanks in advance!

edwards3 wrote on Friday, November 16, 2012:

The Eclipse page you reference is very very old. Eclipse has moved on a long way from then, but I think it just uses a makefile build not a managed make build.

I’m pretty sure you need to be using arm-stellaris-eabi compiler, not arm-non-eabi compiler. arm-non-eabi will work but is newer and will need the compiler options adjusting, as you have found out.

mjonir wrote on Friday, November 16, 2012:

Thanks for the quick reply!

Yes, it’s indeed a simple makefile, I copied it here:

I had tried pointing to the include directory both in the project and in this makefile (although the bath should be correct as it is there), without success.

For the compiler, I am getting it from the “CodeBench/Sourcery Lite for ARM EABI”. I think the arm-stellaris-eabi is the one included in the paid version?

rtel wrote on Saturday, November 17, 2012:

They used to have both available as free lite version downloads, but I don’t know how things have changed since they were acquired by Mentor.

You should be able to use the arm-non-eabi-gcc compiler too, but will have to change the compiler configuration options.  There are other makefiles that show the options needed that you can copy.