The configuration parameter portTICK_RATE_MS in portmacro.h has a misleading name.
To reflect its significance, it should be called: portTICK_PERIOD_MS
Rate is a per time value but period is a time value, here ms.
Inaccurate and misleading names should be avoided - especially for those parameters commonly used in applications of FreeRTOS.
Just a suggestion…