MPlab cc18 compile Failure

nobody wrote on Wednesday, February 23, 2005:

I tried to compile Demo3 from inside MPlab after changing the paths of the various source files and setting the include path to include the .h locations

Any attempt to build or make  the project returns the message
BUILD FAILED - date&time
and no other message
I have checked and rechecked but can’t find the fault

The original project returns the expected cant find… errors
can anyone offer any suggestions

nobody wrote on Wednesday, February 23, 2005:

> BUILD FAILED - date&time and no other message

Not very helpfull of it!

Is it just demo3 or the same for all?  I think there is a difference in demo3 for the compiler path but I don’t know why this would cause a problem.

nobody wrote on Thursday, February 24, 2005:

I tried to compile the RTOS for  the PIC18F6680 and then I got the error Messages
pastet below. I used the following script for the Linker.
Can anyone help me.

MPLINK 3.70.02, Linker Copyright (c) 2004 Microchip Technology Inc. Error - section ‘.udata_heap_1.o’ can not fit the section. Section ‘.udata_heap_1.o’ length=0x00000404 Errors    : 1


FILES c018iz.o
FILES clib.lib
FILES p18f6680.lib

CODEPAGE   NAME=vectors    START=0x0            END=0x29           PROTECTED
CODEPAGE   NAME=page       START=0x2A           END=0xFDBF
CODEPAGE   NAME=debug      START=0xFDC0         END=0xFFFF         PROTECTED
CODEPAGE   NAME=idlocs     START=0x200000       END=0x200007       PROTECTED
CODEPAGE   NAME=config     START=0x300000       END=0x30000D       PROTECTED
CODEPAGE   NAME=eedata     START=0xF00000       END=0xF003FF       PROTECTED

ACCESSBANK NAME=accessram  START=0x0            END=0x5F
DATABANK   NAME=gpr0       START=0x60           END=0xFF
DATABANK   NAME=gpr1       START=0x100          END=0x1FF
DATABANK   NAME=gpr2       START=0x200          END=0x2FF
DATABANK   NAME=gpr3       START=0x300          END=0x3FF
DATABANK   NAME=gpr4       START=0x400          END=0x4FF
DATABANK   NAME=gpr5       START=0x500          END=0x5FF
DATABANK   NAME=gpr6       START=0x600          END=0x6FF
DATABANK   NAME=gpr7       START=0x700          END=0x7FF
DATABANK   NAME=gpr8       START=0x800          END=0x8FF
DATABANK   NAME=gpr9       START=0x900          END=0x9FF
DATABANK   NAME=gpr10      START=0xA00          END=0xAFF
DATABANK   NAME=gpr11      START=0xB00          END=0xBFF
DATABANK   NAME=gpr12      START=0xC00          END=0xCF3
DATABANK   NAME=dbgspr     START=0xCF4          END=0xCFF          PROTECTED
DATABANK   NAME=sfr13      START=0xD00          END=0xDFF          PROTECTED
DATABANK   NAME=sfr14      START=0xE00          END=0xEFF          PROTECTED
DATABANK   NAME=sfr15      START=0xF00          END=0xF5F          PROTECTED
ACCESSBANK NAME=accesssfr  START=0xF60          END=0xFFF          PROTECTED


STACK SIZE=0x100 RAM=gpr11

nobody wrote on Thursday, February 24, 2005:

You need to combine all the small blocks of RAM into a block large enough for the kernel memory pool to fit into.

Take a look at the 18f452.lkr file in the demo/PIC directory to see how this can be done.  Look for the BIG_BLOCK block within this file.

nobody wrote on Sunday, February 27, 2005:

re original message
I found a line at the bottom of the .lnk file defining the compiler program path which I had missed
When I pointed that to my compiler All was fine