MPC5554 Link Error Problem

sadaf235 wrote on Wednesday, December 29, 2010:

im new to freeRTOS and im trying to develop port for MPC5554 but im getting a link failed error…

Link Error: Relocation (10) of Symbol ‘vTaskSwitchContext’ in ‘portasm.o’
is out of range. (1073743208 not in range )

Link Failed

i have added the #pragma push  in task.h for vTaskSwitchContext but no use…im still getting the same error…Please Help

davedoors wrote on Wednesday, December 29, 2010:

Where did you get the port from? I don’t think it is a supported port.

From the error message it sounds like the addressing mode used to access vTaskSwitchContext() from assembly code (if it was done from C code the compiler linker would fix it automatically) cannot do so because vTaskSwitchContext() is too far away in the address range. You could try placing the code in a known section so call related code is close together, or changing the addressing method. These are just guesses though.

sadaf235 wrote on Monday, January 03, 2011:

thanks…yes it is an unsupported port but im trying to make it work….now im placing all the call related code in ‘text’ section and it worked…i mean the errors are gone but now the freeRTOS is not switching tasks….i have created 3 dummy tasks and freeRTOS runs only the last task created (if all are at the same priority) and in case of different priority only the highest priority task…